Splash DamageBlogBrink PC Update Released

Splash Damage Blog

Brink PC Update Released

A new game update for the PC version of Brink is now available on Steam and we've got the changelog here for you. Thanks to the magic of Steam, you'll receive the update automatically the next time you log into your Steam client.

General:

  • Fixed issues with custom ui_fov settings when playing as a client
  • Added support for 2560x1440
  • Slightly improved start up times
  • Fixed crash when clicking in blank area on Training Videos menu
  • Fixed memory leaks on shutdown
  • Fixed Be More Objective leaderboards being incorrectly named

Graphics:

  • Fixed "texture gridding" issues on certain graphics cards
  • Fixed settings being incorrectly applied on the advanced video options screen
  • Improved performance when using Ambient Occlusion
  • Fixed halos not rendering correctly

AI Bots:

  • Removed bot intelligence inhibitors for Freeplay games
  • Adjusted bot behaviour in Campaign games to make teams more evenly matched
  • Changed bots' objective priorities across all game modes
  • Fixed issue with bot difficulty continually dropping

User Interface:

  • Fixed poor server browser performance for users with a large number of items in their history
  • Made server browser refreshes much more responsive
  • Changed server browser to no longer group player counts by max players
  • Added new pop-up text for server browser filters
  • Fixed not being able to sort by favourites column
  • Server browser now retrieves favourites correctly from Steam
  • Fixed arrow keys not working when exiting out of a chat submenu
  • Made it easier to select a default secondary weapon
  • Disabled chat options in solo mode

Dedicated Servers:

  • Can now use net_ip command to assign IPs to server instances
  • Dedicated server binary can now be run as a service, which won't have a CSIDL_PERSONAL virtual folder

56 Comments

Really hope my 4870 is the card which also got fixed. Edit: It did. Awwwww YEAH!
Posted on 13 May, 2011 - 21:24
Any news on a console patch for the lag?
Posted on 13 May, 2011 - 21:26
Nothing for Nvidia 4xx/5xx :\
Posted on 13 May, 2011 - 21:27
I hope that they make it so that the scoreboard will show our actual pings soon, I hate this green bar crap...
Posted on 13 May, 2011 - 21:27
green bar is a result of console porting, it seems. 1+ for ping!
Posted on 13 May, 2011 - 21:28
A new story entry has been added: [drupal=806]Brink PC Update Released[/drupal]
A new game update for the PC version of Brink is now available on Steam and we've got the changelog here for you. Thanks to the magic of Steam, you'll receive the update automatically the next time you log into your Steam client.
Posted on 13 May, 2011 - 21:31
Nothing for Nvidia 4xx/5xx :\
I dunno man, I think I see some improvement. 5770. The graphics effects, deff mean something. Seems like some parts I get higher FPS, some I dont though.
Posted on 13 May, 2011 - 21:33
Nice to see you working hard on fixing everything! :) If only the SDK was announced for the near future I would be perfectly happy with BRINK ;)
Posted on 13 May, 2011 - 21:33
I dunno man, I think I see some improvement. 5770. The graphics effects, deff mean something. Seems like some parts I get higher FPS, some I dont though.
he's talking about nvidia, 5770 is amd................
Posted on 13 May, 2011 - 21:35
I just played on the new patch and the ui_fov doesn't take into account whether or not you are using the adjusted iron sights. I have my ui_fov set to 90 but when I go to use my sites it sets my FOV to 70, essentially making the adjusted iron sights useless.
Posted on 13 May, 2011 - 21:38
dude. i thought youre like a troll cause this sounds too good to be true. so fast and so working. the gridding issue is gone. i need a gfx card upgrade though. game doesnt run too good on a 4870. but its like a thousand times better than before. im even having fun against bots, 2on2 though. awsome. :D
Posted on 13 May, 2011 - 21:40
Speagles, is it only the adjsuted iron sights? Have you tried normal iron sights, cogs, red dot, etc? I also had g_fov and ui_fov backwards
Hi all, This issue has been addressed and will be with you via an update very shortly. Once you recieve the update, the cvar for changing fov is now 'ui_fov' rather than the previous 'g_fov'. On a side note, there is no aim assist on the PC version at all. :)
Posted on 13 May, 2011 - 21:41
Is there no console updates? Hopefully they ewill get to work on it soon. If not, its looking dark for console users...
Posted on 13 May, 2011 - 21:45
i ****in love you SD
Posted on 13 May, 2011 - 21:48
Nothing for Nvidia 4xx/5xx :\
Yes, still having "Nvidia OpenGL driver has lost connection with the display driver" crash after this patch with my GTX 570. :(
Posted on 13 May, 2011 - 21:48
Really hope my 4870 is the card which also got fixed.
Amen to that!
Posted on 13 May, 2011 - 21:50
Awesome! However does Refuel have sound?!
Posted on 13 May, 2011 - 21:51
Is the FOV issues when using smart and sprinting fixed. This was a major issue that was said to have already been fixed and would be implemented in the second patch.
Posted on 13 May, 2011 - 21:51
Is the FOV issues when using smart and sprinting fixed. This was a major issue that was said to have already been fixed and would be implemented in the second patch.
Yes, read the notes..... the new command is ui_fov
Posted on 13 May, 2011 - 21:52
Fixed issues with custom ui_fov settings when playing as a client
Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you. Thank you.
Posted on 13 May, 2011 - 21:54
Lovely. Thanks.
Posted on 13 May, 2011 - 22:08
Cheers, enjoyed my first game online :) Though coop and joining your friends games is still buggy for me.
Posted on 13 May, 2011 - 22:09
Any word when/if this patch is coming to the consoles? I'd hate to see the console side of things be treated like a dungeon troll
Posted on 13 May, 2011 - 22:09
Wow, I just played campaign and the bots actually did their ****. Too bad this happened after the reviews.
Posted on 13 May, 2011 - 22:10
anyone else have a lower than normal sound volume? i have to increase my system volume like 30-40% more compared to other games. the game volume is already maxed in game settings.. not a big deal just strange. would it be possible to get a fov cvar for weapon model? when increasing fov to say 90 (which is the proper fov for 16:9 screen) the model looks kinda stretched/distorted.
Posted on 13 May, 2011 - 22:19
when increasing fov to say 90 (which is the proper fov for 16:9 screen)
Excuse you?
Posted on 13 May, 2011 - 22:37
I'm disappointed that the sound issues aren't mentioned. I haven't tried yet, but if it's not in the logs.
Posted on 13 May, 2011 - 22:43
While the only thing I noticed changed was the browser and filtering, since i had no real issues with anything else or at least none that I noticed, I definitely like the rapid patch to begin fixing known, and some unknown, problems. Here's to hoping the next patch will clear up an issue I keep running into which is audio fading so the only thing I'll hear is command posts humming.
Posted on 13 May, 2011 - 22:48
This is earlier than i expected :D
Posted on 13 May, 2011 - 23:06
Thanks for the soon patches! SD works hard on the issues and I think we will have the most of them addressed in the nearest future. Besides I have no technical problem at all... :)
Posted on 13 May, 2011 - 23:09
"Here's to hoping the next patch will clear up an issue I keep running into which is audio fading so the only thing I'll hear is command posts humming." So I assume sound still has issues then. Oh well.
Posted on 13 May, 2011 - 23:12
Very NICE second patch, keep it up devs! :D
Posted on 13 May, 2011 - 23:21
Great work SD! I wuv you.
Posted on 13 May, 2011 - 23:26
anyone else have a lower than normal sound volume? i have to increase my system volume like 30-40% more compared to other games. the game volume is already maxed in game settings.. not a big deal just strange. would it be possible to get a fov cvar for weapon model? when increasing fov to say 90 (which is the proper fov for 16:9 screen) the model looks kinda stretched/distorted.
Apparently the game uses vertical FoV instead of horizontal FoV (think like BC2) Use this calculator to figure out what you should use to get a proper 90 horizontal FoV.
Posted on 13 May, 2011 - 23:29
Apparently the game uses vertical FoV instead of horizontal FoV (think like BC2) Use this calculator to figure out what you should use to get a proper 90 horizontal FoV.
Many games seem to be using vertical instead of horizontal these days, wonder why?
Posted on 14 May, 2011 - 00:12
you think you can unlock the 16 slots for servers...
Posted on 14 May, 2011 - 00:14
Fantastic game. My rig is decent and the game was barely playable but hardly enjoyable. Now that the patch fixed the gridding issues, the game looks fantastic and the performance is way way better. I could enable shadows, high textures as well as anti-aliasing with decent framerate (haven't checked numbers, but it felt smooth when quickly moving the mouse, that's what I wanted. Brink definitly rocks.
Posted on 14 May, 2011 - 00:19
I lost my save due to this update. Good to see a patch though.
Posted on 14 May, 2011 - 00:35
What's the word about the performance for AMD users with 11.5a installed?
Posted on 14 May, 2011 - 01:25
Patch didn't do much in terms of performance. It's still pretty bad. I'm on 11.5a drivers with a Radeon HD 6990 4GB, 4.2ghz i7, 6gb ram.
Posted on 14 May, 2011 - 07:44
It didn't fix the lag for me... It lagged a lot less yesterday night but now it started again. Busy servers I guess? Please fix it. I've got an ATI Radeon HD 5450.
Posted on 14 May, 2011 - 09:51
With the recent "fix", I honestly dont see much intelligence in the enemy still, even on hard. The only real difference that i have noticed is that friendly bots are slightly more prone to do objectives if they are nearby. But this is balanced by the other thing i have noticed : both teams now tend to huddle together in giant groups. The enemy team now sits together in a giant group in front of the objective now. Managed to hit 6 with a Molotov just now. Friendly bots do something similar, sticking together in a group (yay), but only moving forward if there are no enemies around (boo). So the matches now, for me at least, consist of me trying to nade and then kill an entire team so that my team will move forward for an easy win.
Posted on 14 May, 2011 - 09:52
Yes, still having "Nvidia OpenGL driver has lost connection with the display driver" crash after this patch with my GTX 570. :(
Me too :( I just hope that gets fixed soon, although I only get it about once every 3-4 hours so its no big deal. Still having fun with the game. Good Job SD, keep up the hard work.
Posted on 14 May, 2011 - 10:18
There's still an issue with FoV; when using adjusted sights it zooms in like the regular iron sights do.
Posted on 14 May, 2011 - 11:19
I wished this fixed the part where I can't even launch the game without it crashing. I know these kinds of things must be tedious and I have the utmost respect for the developers, but as much as patches that fix gameplay are great they don't mean much to those of us who can't even start the game we've purchased yet. I'm still glad I bought it, but dear god the waiting is tearing my soul apart.
Posted on 14 May, 2011 - 15:11
thanks for the update guys. But i dont think this update did much to the lag most of the ATI card users are getting. I got a 5870.. and my fps wont get past 40...... you did an awesome job on this game. i support you 100% but please fix this issue so people can actualy start enjoying this masterpiece!
Posted on 14 May, 2011 - 19:56
for me its the same like for most of the ATI useres ... like many ppl said u did an awesome job on this , but pls fix this huge FPS problems. i got crossfire 5770 and i get like 30 - 40 fps . depends on map and situation. if i lower resulotion to minimun and go for low details and no shadows and stuff i sometimes get 60 fps but this runs only for like 6 min after the fps drop down again. best regards and keep on the good work on this awesome game. what i also realized is that if iam in mumble and try to start the game , it always crashes in the intro screen ... if iam not in mumble it starts normally ... reFused ....
Posted on 14 May, 2011 - 20:28
Many games seem to be using vertical instead of horizontal these days, wonder why?
Because when everyone was running 4:3 it didn't make a difference Now 16:9 and 16:10 are becoming the norm so switching to vfov makes sense
Posted on 15 May, 2011 - 01:00
With the recent "fix", I honestly dont see much intelligence in the enemy still, even on hard. The only real difference that i have noticed is that friendly bots are slightly more prone to do objectives if they are nearby. But this is balanced by the other thing i have noticed : both teams now tend to huddle together in giant groups. The enemy team now sits together in a giant group in front of the objective now. Managed to hit 6 with a Molotov just now. Friendly bots do something similar, sticking together in a group (yay), but only moving forward if there are no enemies around (boo). So the matches now, for me at least, consist of me trying to nade and then kill an entire team so that my team will move forward for an easy win.
Thats the name of the game atm lol
Posted on 15 May, 2011 - 01:07
hey guys, just signed up to share my experiences with the game. first my specs [LIST] [*]windows 7 sp1 [*]intel core 2 quad q9550 @ 3.1 ghz [*]sapphire ati hd5850 [*]4 gig 1066 OCZ RAM [*]xfi pci-e fatality sound card [/LIST] My performance pretty much whatever the graphics settings is not very good. usually between 25-50 tops. This is using the 11.5ar rc2 drivers you guys are recommending. I am also getting some weird flickering during the cutscenes with the background items that can be seen here http://www.youtube.com/watch?v=773WdbzfgEI. I am also having issues with garbled text. In terms of sound, in the cutscenes and loading screen the voices come through random channels. ALso sometimes when i join servers all i hear is the medic beep, other people's gun. random background noise or nothing at all. Also the friendly AI is dumb as... I really want to love this game, and I have put almost 20 hours into it so far but these bugs need to be addressed. I know you guys are doing your best and I wish you all the luck but how things like this pass QA is beyond me...
Posted on 15 May, 2011 - 02:18
I also have garbled text since the patch and use a gtx 580. I did not have this issue prior to the patch.
Posted on 15 May, 2011 - 02:36
im also getting the same bugs. sometimes there is no sound at all in the game. after this patch that issue with the garbled text also started for me. i dont even want to talk about the fps in the game, its so horrible. just unplayable. and my pc beats the recommend requirements for this game by far. got a 5870, 4 gb ram, amd phenom x4 @2.4 ghz
Posted on 15 May, 2011 - 02:40
Thank's, but I'm still having major issues with my 5770. Everything low with FPS configs and still getting 20-40 FPS. I've been re-installing some of the AMD drivers and I've messed up and lost 20-30 FPS.
Posted on 15 May, 2011 - 12:23
Product Update - Valve General: Fixed issues with custom ui_fov settings when playing as a client Added support for 2560x1440 Slightly improved start up times Fixed crash when clicking in blank area on Training Videos menu Fixed memory leaks on shutdown Fixed Be More Objective leaderboards being incorrectly named Graphics: Fixed “texture gridding” issues on certain graphics cards Fixed settings being incorrectly applied on the advanced video options screen Improved performance when using Ambient Occlusion Fixed halos not rendering correctly AI Bots: Removed bot intelligence inhibitors for Freeplay games Adjusted bot behaviour in Campaign games to make teams more evenly matched Changed bots’ objective priorities across all game modes Fixed issue with bot difficulty continually dropping User Interface: Fixed poor server browser performance for users with a large number of items in their history Made server browser refreshes much more responsive Changed server browser to no longer group player counts by max players Added new pop-up text for server browser filters Fixed not being able to sort by favourites column Server browser now retrieves favourites correctly from Steam Fixed arrow keys not working when exiting out of a chat submenu Made it easier to select a default secondary weapon Disabled chat options in solo mode Dedicated Servers: Can now use net_ip command to assign IPs to server instances Dedicated server binary can now be run as a service, which won't have a CSIDL_PERSONAL virtual folder
Would be nice to see some of that changes for the Xbox 360 plus a fix for the game-freezes and permanent lag.
Posted on 15 May, 2011 - 12:51
it's all nice, all this updates and stuff... but still I'm not able to play this game. in menu works fine but when I want actualy to play the game, it just crash back to desktop, I try all solution's and no luck... is there gona be any future updates for this game? cheers...
Posted on 16 May, 2011 - 11:12
Im running 2 5870's and it runs great, but I keep having text over turrets or when Im checking guns and such just be garbled junk. I switched them out for my pair of 5770's to see if it was the cards, but I get the same thing. Is this just an issue with ATI? Game runs awesome besides that. Thank you SD for the AI changes, I ****ing love BRINK!!!
Posted on 16 May, 2011 - 14:21
Nice Update!!! Now waiting for Linux Server Files to Set Up the the Clan Server :wink: Any news so far? Regards from Germany, FaL* Daride
Posted on 16 May, 2011 - 14:38